PaperCut Pop-ups being sent to wrong user

Minor incident Print & Copy
2 weeks, 6 days, 36 minutes, 45 seconds

Updates

Resolved

Our problem with firewall NAT causing this to happen is now resolved.

November 24, 2020 · 09:01 +11
Investigating

We had a major issue with dns records. it is fixed now. we will continue to monitor this issue for a few more days.

November 12, 2020 · 09:21 +11
Investigating

PaperCut pop-up prompts are sometimes being sent to the wrong issue. We are currently investigating the cause of this issue.

November 4, 2020 · 08:25 +11

← Back