Staff Printer Out Of Service

Minor incident Print & Copy
1 day, 5 hours, 37 minutes, 3 seconds

Updates

Resolved

broken parts replaced

October 13, 2020 · 14:31 +11
Issue

Staff Printer Needs to be Serviced, related technician will come in soon.

October 12, 2020 · 08:55 +11

← Back