MYST Printer Out Of Service

Minor incident Print & Copy
1 day, 6 hours, 4 minutes, 16 seconds

Updates

Resolved

broken feeder replaced

October 13, 2020 · 14:32 +11
Investigating

software update successfully applied and device is operational

October 13, 2020 · 14:32 +11
Issue

Printer has got software issues. Konica Minolta tech will come in monday morning. You can check status page for any updates

October 12, 2020 · 08:29 +11

← Back