TBlock printer requires service

Minor incident Print & Copy
1 month, 1 week, 4 days, 22 hours, 9 minutes, 22 seconds

Updates

Resolved

printer was serviced today by konica minolta technician.

October 5, 2020 · 14:29 +11
Issue

TBlock printer has issues in the finisher part. Konica-minolta is aware of it but unfortunately because of lockdown cannot attend school. They will arrange a service at the end of lockdown

August 24, 2020 · 15:53 +11

← Back