TBlock Printer out of service

Minor incident Print & Copy
3 hours, 38 minutes, 51 seconds

Updates

Resolved

Konica Minolta came in this evening and he had a solid fix on the device. This might happen again because it was a fix not replacement. Hope it works till we get replacements

June 1, 2020 · 15:22 +11
Investigating

this issue is the result of a broken part in finisher unit. the part is not a consumables, according to KonicaMinolta technician, the whole FS-533 unit should be replaced. The problem is that they do not have any in stock, so we might have to wait for their next batch.

June 1, 2020 · 11:48 +11
Investigating

TBlock Printer indicating paper jam in its finisher unit

June 1, 2020 · 11:45 +11

← Back